Most websites today use php to run various web applications/scripts. Your business website is most likely using php to operate things like a simple web form or a complex CMS like Drupal or WordPress.

Newer versions of Php are released regularly by the Php community. Each release branch of Pph is supported for two years from its initial stable release. During this period, bugs and security issues are fixed and released in regular point releases. After this two year period of active support, each branch is then supported for an extra year for critical security issues only. Once the three years of support are over, the branch reaches its end of life and is no longer supported.

Php Community Supported Versions

So why is this important?

If you operate a website, then it’s important to know what version of php is running on your website. Once the php community stops releasing security updates for a specific PHP branch, any website still using the outdated PHP branch (eg PHP 5.x, 7.1, 7.2 and 7.3) will be vulnerable to data breach and malicious attacks by hackers.

What can be done?

As part of operating one of the most secure hosting platforms for business customers, all BEZA hosted web applications have been upgraded to PHP 7.4.x as of Nov 01, 2021.

As a BEZA customer, you can check your hosting control panel to see what version of php is running on your website(s) (see image below):

How to check PHP version via your BEZA Web Hosting control panel

Currently, we offer two php branches to choose from: PHP 7.4.x or PHP 8.0.x.

We recommend all customers use PHP 7.4.x and plan for upgrading to PHP 8.0 soon.

If your website was developed by our professional Web Developers, then it’s 100% fully compatible with php 7.4 since June 01, 2018.

We recommend everyone to check with their web developer to confirm if your web application is fully compatible with php 7.4 or 8.0. Your web developer can refer to the php community migration documentation for more information.

If you don’t have a web developer, our professional Website Maintenance team can perform an initial analysis to determine the compatibility of your website with php 7.4 or 8.0.

Switch to php 7.4.x Today!

We’ve made it very easy for our web hosting customers to switch their website php version. First, our engineers have automatically switched all hosted websites from PHP 7.3.x to 7.4.x. You can verify this by login to the BEZA hosting control panel.

Secondly, we have verified all hosted websites load fine with no critical errors. HOwever, we do recommend all customers to run additional tests to ensure their web application are fully compatible with php 7.4. Refer to “What can be done” above for ways to check if your application is compatible with php 7.4.

Your account security is one of our top priority. As your web hosting provider, we want to ensure we can continue to secure your website(s) and hosted application(s). If your web application doesn’t currently support php 7.4, contact us for help 24×7.

Chat LIVE with us

Pin It on Pinterest